CCIE Quiz

 
دلوقتي حاج سعيد عنده مشكلة
سعيد دلوقتي في لاب ال
CCIE
بتاع الراوتينج و السويتشنج و ديه التوبولوجي اللي عنده
زي مشايفين…حاجة بسيطة جدا 😛
اتطلب منه انه يشغل
OSPF/EIGRP
ويعمل
redistribution مابينهم و حاجات تيت كدة
والراجل صراحة مقصرش..عمل ده كله و زيادة عليه كمان…بس مشكلته اللي مفكرش فيها وهو بيحضر للامتحان هي.. انه ازاي يعمل
test
في وقت قصير
??

هل معقول اني ادخل علي كل راوتر واقعد اجرب هل كل انترفيس قايم و بيقدر يبنج اللي قدامه؟!..ديه فيها ساعة..انا فاهم كويس لو فيه مشكلة هقدر احلها ان شاء الله..بس الاقيها الاول!!
حاج سعيد يعمل ايه؟ :)…بصورة تانية…هل فيه امر في سيسكو يخليك تعمل بينج علي كل الدنيا ديه كلها..ولا مفيش حاجة زي كدة اصلا؟!

 

 

Solution
حل مشكلة الحج سعيد بسيطة ..يعمل بس الامر ده
ping 255.255.255.0
🙂
كدة هيقدر يعمل بينج علي كل النتورك اللي معمولها
attach
علي اي راوتر
ممكن كمان يضيف بعديها
rep 1
يعني يعمل
repeat
لاي بينج علي نتورك مرة واحدة بس ميعقدش يكررها
جربوها علي ال
GNS3
ظريفة
🙂

======================

there’s script in linux (ping_all) that will ping all network

Advertisements

CCIE Lab is visiting Egypt!

انتوا عارفين طبعا ان لاب ال
CCIE
عشان تمتحنه مالوش غير 3 اماكن..امريكا و دبي و المانيا تقريبا
فده بيخلي ناس كتير بتكتفي بس بأمتحان ال
Written

بتاعه و تنفض للاب
بس فيه حاجة دلوقتي اسمها ال
Mobile Lab
سيسكو عملتها…كل مدة بتروح دولة معينة وتعمل فيها اللاب ده للي عايز يمتحنه
اللاب هو اللي هيجيلك لحد عندك :D…
سيسكو بدءت تضيف اماكن جديدة غير التلاتة دول…ومنهم مصر 🙂
ده جدول فيه مواعيد اللابات ال
CCIE
في كل دولة وكل فترة بيتعمله تحديث
https://learningnetwork.cisco.com/docs/DOC-3224

كان فيه لاب اتعمل في مصر في فبراير اللي فات…في الراوتينج والسيكيورتي…
السنة اللي جاية ان شاء الله هيبقي نفس اللاب ده هيتعمل في شهر مارس…فشدوا حيلكوا بأة للي عايز يحجزه

🙂

Free Cisco Switching LAB

ال
GNS3
مش بي
Support
حاجات كتيرة في سويتشات سيسكو…هو بيعرف يعمل سيموليشن للراوترات كويس..بس السويتشات فيه حاجات مش هتعرف تعملها بسبب مشاكل في السيموليشن بتاع الهاردوير وبالتالي مش كل اللابات و الاوامر الموجودة في السويتش الحقيقي هتلاقيها موجودة في السويتش اللي في ال
GNS3
غير انك مش هتعرف تعمل لينكات فايبر عليه
فيه تلات حلول للي عايز يعمل لابات السويتشنج

اول حل
انك تشتري سويتش حقيقي …ايه يعني تدفع 60 الف جنيه عشان تشتري سويتش
Cisco 4500?
كلام فارغ
😀

فيه حل تاني لو مش هتشتري سويتشات…انك تروح لشركات زي
INE
و
IPEXPERT
بتدفعلهم حوالي 200 دولار ويدولك اكسس علي سويتشات حقيقية عندهم في الراك لفترة معينة
وتعمل اللابات بتاعتك و شكرا

الحل التالت
نفس الحل التاني بس ببلاش
واحد جيه و اشتري سويتشات ووصلها في توبلوجي معينة و حط
Real IP’s
عليهم و بأة من حق اي حد يدخل و يعمل اللابات عليهم
مش محتاج تعمل تسجيل او تدفع فلوس او اي حاجة
اعمل بس
telnet
علي الايبهات اللي مكتوبة في اللينك ده
http://labswitch.blogspot.com/
هو هيديلك اكسس لمدة ساعة..ولو قعدت 10 دقايق مش بتعمل حاجة علي جهاز معين هيفصلك منه عشان غيرك يدخل…ولو معرفتش تدخل علي جهاز يبقي غالبا واحد غيرك داخل عليه دلوقتي…10 دقايق و حاول تاني
زي مشايفين في ال
topology
هما 6 سويتشات مابينهم
Full Mesh
وبالتالي لو دخلت علي 3 سويتشات منهم يبقي اعتقد انك هتعرف تعمل اغلب اللابات بتاعة السويتشنج
Enjoy

Network Diagram

http://3.bp.blogspot.com/-pKeLivMErZY/T9pQzmSNN0I/AAAAAAAAAJQ/fHlKOEpsEiw/s1600/Diagram2a.3.jpg

Route Reflectors

Route reflectors

BGP requires that all BGP peers in the same autonomous system form an iBGP session with each others. This is too difficult in many environments. Route reflectors are fully functional iBGP speakers that form iBGP sessions with other iBGP speakers, and they also perform a second function – they forward routes from other iBGP speakers to route reflector clients. The route reflector clients and clients form a cluster.

clip_image001[4]

 

R3(config-router)# router bgp 65000
R3(config-router)# neighbor 198.18.13.1 remote-as 65000
R3(config-router)# neighbor 198.18.13.1
route-reflector-client//add neighbor 198.18.13.1 and tell him “I’m your route reflector”

R3(config-router)# neighbor 198.18.23.2 remote-as 65000
R3(config-router)# neighbor 198.18.23.2 route-reflector-client
R3(config-router)# neighbor 198.18.34.4 remote-as 65000
R3(config-router)# neighbor 198.18.34.4 route-reflector-client
R3(config-router)# neighbor 198.18.35.5 remote-as 65000
R3(config-router)# neighbor 198.18.35.5 route-reflector-client

 

 

R4(config-router)# do show ip bgp | begin Network
   Network          Next Hop            Metric LocPrf Weight Path
*>i198.18.111.1/32  198.18.13.1              0    100      0 i
*>i198.18.222.2/32  198.18.23.2              0    100      0 i

 

R5(config-router)# do show ip bgp | begin Network
   Network          Next Hop            Metric LocPrf Weight Path
*>i198.18.111.1/32  198.18.13.1              0    100      0 i
*>i198.18.222.2/32  198.18.23.2              0    100      0 i

Capture traffic in router

 

clip_image001[4]

 

 

Supported platform

1.cisco 1841

2.cisco 2800

3.cisco 3800
 

Configuration

Router(config)# ip traffic-export profile BASIM //create a monitoring profile

 

Router(config-rite)# interface FastEthernet 0/0 //the monitored interface (the interface that you connect your PC (wireshark) to it)

 

Router(config-rite)#bidirectional //monitor the incoming and outgoing traffic

Router(config-rite)# mac-address 0018.8BBF.55CF

 

 

Router(config)# interface s0/0 //the interface that you want to monitor

Router(config-if)# ip traffic-export apply BASIM

 

Router# traffic-export interface fastethernet0/0 start

 

Router# show ip traffic-export

Router IP Traffic Export Parameters

Monitored Interface s0/0

Export Interface FastEthernet0/0

Destination MAC address 0018.8BBF.55CF //your mac address

bi-directional traffic export is off

Input IP Traffic Export Information Packets/Bytes Exported 0/0

Packets Dropped 0

Sampling Rate one-in-every 1 packets

No Access List configured

Profile one is Active

 

 

note that only IP traffic is being replicated, and we lose any lower-layer headers (like PPP) due to the change in medium.

BGP Advanced

1.Change the advertised Local Preference

 

1.Create a Route map to change the local preference to 100 (for ISP you want to prefer)

R2(config)#route-map LOCALPREF-BB1

R2(config-route-map)#set local-preference 100

R2(config-route-map)#exit

 

2.Create a Route map to change the local preference to 200 (for the 2nd ISP)

R2(config)#route-map LOCALPREF-BB2

R2(config-route-map)#set local-preference 200

R2(config-route-map)#exit

 

3.Configure the Route Map under the BGP process

R2(config)#router bgp 65001

R2(config-router)#neighbor 172.16.1.1 route-map LOCALPREF-BB1 in//I (R1) will set any routes coming from you(BB1:172.16.1.1) as it has local preference of 100

 

R2(config-router)#neighbor 172.16.2.2 route-map LOCALPREF-BB2 in //I (R2) will set any routes coming from you(BB2:172.16.2.2) as it has local preference of 200

R2(config-router)#exit

 

 

2.Chnage the Actual AS hops

 

1.Create a new route map that will fake the number of AS

R2(config)#route-map ASPATH 10

R2(config-route-map)#set as-path prepend 65001 65001 //advertise your routes with two AS added to the real AS

R2(config-route-map)#exit

 

2.Apply it on bgp

R2(config)#router bgp 65001

R2(config-router)#neighbor 172.16.1.1 route-map ASPATH out //advertise your AS to neighbor 172.16.1.1 and add two fake AS

R2(config-router)#end